Audiosoft Forums : EJukebox Last active: Never
Not logged in [Login - Register]
Go To Bottom

Printable Version | Subscribe | Add to Favourites   Post new thread Poll:
Author: Subject: Oh No, eJukebox hangs...
Demnos
Member
***




Posts: 207
Registered: 3-11-2003
Location: Berlin, Germany
Member Is Offline

posted on 10-13-2003 at 11:48 AM Edit Post Reply With Quote
Oh No, eJukebox hangs...

After months of running without probs and without changing anything on my system, this morning eJukebox (3.5) no longer works, but hangs after starting Winamp, i.e. even before loading its own interface. It takes up 99.9% of CPU time and the system is super slow.

I uninstalled and reinstalled eJukebox. It then comes up fine, but as soon as the database is rebuilt (rebuilding itself seems to work fine), it starts Winamp, plays one song and sits forever on "Synchronizing..." It then uses again 99.9% CPU and cannot be terminated.

After rebooting the PC, I have the initial situation that eJukebox will start Winamp but not its own screen.

Help, what can I do???

I use WINAMP 2.91
View User's Profile View All Posts By User U2U Member
Demnos
Member
***




Posts: 207
Registered: 3-11-2003
Location: Berlin, Germany
Member Is Offline

posted on 10-14-2003 at 01:24 PM Edit Post Reply With Quote
Solved...kind of:

After trying various de- and re-installs (also reinstalling Winamp, MDAC, IE etc). I finally had the great idea to try to first install 3.5 then immediately downgrade to 3.4 and finally it works again!!!!

I can now consistently reproduce the problem: Upgrade to 3.5 - eJukebox hangs up. Reboot System, downgrade to 3.4 - eJukebox runs again. Do the upgrade to 3.5 again: Yep, system hangs!

This means there is some kind of major bug in 3.5 and also that I am now unable to ever use 3.5 or later versions until this bug is fixed. The weird thing is that 3.5 was running fine for 3-4 days.

Any ideas where I could look, I would really prefer to run 3.5 and future versions rather than being stuck on 3.4. forever.
View User's Profile View All Posts By User U2U Member
ochristmas
Member
***




Posts: 119
Registered: 8-27-2003
Location: UK
Member Is Offline

posted on 10-14-2003 at 02:37 PM Edit Post Reply With Quote
I would imaging that it must be something that was introduced in 3.5 that has now been corrupted - so the obvious thing is rating - maybe one of your mp3 has a corrupt rating that 3.4 doesnt look at or use but later versions do. Sounds logical. Maybe backup your database - reinstall 3.4 with just one album scanned - then upgrade....

but then again im just a monkey without an organ grinder ;)
View User's Profile View All Posts By User U2U Member
Audiosoft
Super Administrator
*********




Posts: 3390
Registered: 3-11-2003
Member Is Offline

posted on 10-14-2003 at 02:48 PM Edit Post Reply With Quote
v3.4 had ratings too so it is probally not that.

Odd that is initially worked and then stopped working....

I am not sure but, if you changed the screen resolution from what it was when eJukebox last ran it could possible cause problems when it is restarted. As eJukebox now remembers EDV and eJukebox height and restores on startup.

How long did you wait when it was using 100% cpu? It may have been trying to download an image.

Also, when you uninstalled eJukebox did you delete the ejukebox.ini file?




:cool: Audiosoft
View User's Profile E-Mail User Visit User's Homepage View All Posts By User U2U Member
Demnos
Member
***




Posts: 207
Registered: 3-11-2003
Location: Berlin, Germany
Member Is Offline

posted on 10-14-2003 at 07:12 PM Edit Post Reply With Quote
Thanks for the suggestions and help. I did erase the entire program directory after uninstall, so yes, the ejukebox.ini file was also gone. I also waited 4 hours once, so I don't think the program was doing anything.

For some strange reason, it is now working again, and I know nobody is going to believe me, but the only thing I did different this time (from the other 4 times I tried) was to use a different directory name for the install.

Before, I always did this: eJukebox install into c:\ejukebox\myname. (Because I have another copy in c:\ejukebox\wifename)

After getting the hanging system, I rebooted, did uninstall, removed c:\ejukebox\myname, then installed from the original setup files, but again into c:\ejukebox\myname.

This time, I chose c:\ejukebox\newname and everything works.

It sounds too crazy and maybe it was just coincidence, but maybe there is some entry in a file outside of eJukebox or in the registry or in a cache/temp file that needed to be overwritten with a new directory name? Weird.

Thanks again for helping, I'll keep an eye out if I can reproduce this again.
View User's Profile View All Posts By User U2U Member
Demnos
Member
***




Posts: 207
Registered: 3-11-2003
Location: Berlin, Germany
Member Is Offline

posted on 11-4-2003 at 09:23 AM Edit Post Reply With Quote
Interesting observation: The hanging eJukebox came back last night. And it was exactly when I selected a track from the same album where it was hanging up last time: the album "Melody A.M." by "Röyksopp".

Since eJukebox always automatically plays the last track when the system is restarted, there was no way for me to get back into eJukebox.

Again, downgrading to 3.4 was the solution: After downgrading, eJukebox came up fine, I could then remove the offending track from the playlist and go back to 3.53 without problems.

I played around some more and now I know it is definitely related to playing *any* track from that album: As soon as it starts playing a song from the album, eJukebox stays forever on "Synchronizing"

The obvious thought was that it may have to do with the Band name containing an "ö" character. But that is not it, as I have another album by Röyksopp and that one doesn't cause any problem. I'll be playing some more with the tags to see what could be wrong.
View User's Profile View All Posts By User U2U Member
loxab
Newbie
*




Posts: 1
Registered: 7-21-2018
Member Is Offline

posted on 7-21-2018 at 05:02 AM Edit Post Reply With Quote
After months of running without any problems and without changing of my system there is error come that is Audio soft. This error come because of essays reviews uk that may cause for our system that why we solved it as soon as possible.
View User's Profile View All Posts By User U2U Member
Post new thread Poll:

Go To Top

Audiosoft Home | Download EJukebox for Windows | Register EJukebox
©2016 Audiosoft Network. All rights reserved.
[queries: 16]
HTML5 Color Picker for CSS Opacity
Short Url Service with Stats