Audiosoft Forums : EJukebox Last active: Never
Not logged in [Login - Register]
Go To Bottom

Printable Version | Subscribe | Add to Favourites   Post new thread Poll:
 Pages:  1  2
Author: Subject: eJukebox 4.89
Audiosoft
Super Administrator
*********




Posts: 3390
Registered: 3-11-2003
Member Is Offline

posted on 8-31-2007 at 02:36 AM Edit Post Reply With Quote
eJukebox 4.89

4.89 Updates:
-fixed eJukebox not restoring last carousel setting (enabled/disabled) on next start up
-fixed eJukebox not remembering 'always show duplicates' option setting
-eJukebox now allows for an .artistheader in albumscroll.dis to independently skin artist name headers in the album list.
-updated full installer so that it no longer attempts to replace existing system winsock files when they already exist

4.88 Updates:
-added .WV audio file support.
-added password protect option for 2Web browser interface.
-added Pause and Finish Later buttons to database update window.
-virtual keyboard skin updated

4.87 Updates:
-fixed closing ejukebox with right side hidden not restoring right side layout settings properly on next startup
-fixed problem with some mp3 id3 tags that was causing eJukebox to be unable to add the file
-fixed eJukebox stuck loading options at startup
-scrollbuttons back to enabled by default again


4.86 Update:
-Fixed it so dropping .mp4, .m2v and .mpeg files on the playlist works correctly and adds new files to the database


To Install v4.88:
Shutdown eJukebox and download and run the upgrade from HERE




:cool: Audiosoft
View User's Profile E-Mail User Visit User's Homepage View All Posts By User U2U Member
drewster98
Junior Member
**




Posts: 65
Registered: 4-26-2007
Member Is Offline

posted on 9-8-2007 at 02:23 AM Edit Post Reply With Quote
No updates for over a week?!?!? I feel naked!!!
View User's Profile View All Posts By User U2U Member
Dragon_slayer
Member
***




Posts: 116
Registered: 10-20-2006
Member Is Offline

posted on 9-20-2007 at 07:46 AM Edit Post Reply With Quote
Audiosoft,
You mentioned in an earlier post that you were considering creating a separate database for music videos, I was just wondering if this is still in the works.
View User's Profile View All Posts By User U2U Member
Audiosoft
Super Administrator
*********




Posts: 3390
Registered: 3-11-2003
Member Is Offline

posted on 9-30-2007 at 11:01 AM Edit Post Reply With Quote
v4.87 is up. Another small update. I downloaded a mp3 album and v4.86 wouldn't add the songs so I figured out what was going wrong with the id3 tags and corrected it in v4.87. Hopefully that will fix it for you if you were having a problem adding songs. Working on v4.88 and .wv support now...

Dragon_slayer, Regarding the music videos... I don't think a separate database is very practical right now. You have the Videos item on the Tools menu already.




:cool: Audiosoft
View User's Profile E-Mail User Visit User's Homepage View All Posts By User U2U Member
Pirk
Posting Freak
*****


Avatar


Posts: 3973
Registered: 3-11-2003
Location: France
Member Is Offline

posted on 9-30-2007 at 12:52 PM Edit Post Reply With Quote
Thanks for this small update Audiosoft.

I noticed the eJukebox layout is also not restored properly after a system hibernation: eJ resumed in super EDV while it was in "super non-EDV" before the system low power mode. I hope you follow me!




:cool: Pirk
View User's Profile Visit User's Homepage View All Posts By User U2U Member
drewster98
Junior Member
**




Posts: 65
Registered: 4-26-2007
Member Is Offline

posted on 10-1-2007 at 10:10 PM Edit Post Reply With Quote
Pirk, I'm in the same boat as you. I thought I did something but I have to constantly restore the layout after my anti-virus update box pops up and installs an update.
View User's Profile View All Posts By User U2U Member
Pirk
Posting Freak
*****


Avatar


Posts: 3973
Registered: 3-11-2003
Location: France
Member Is Offline

posted on 10-2-2007 at 09:26 AM Edit Post Reply With Quote
drewster98, OK your antivirus changes the ejukebox layout! Bad luck if it is updated everyday.. What is your antivirus name? Is it on vista?
My antivirus is AVG and I'm on vista, but AVG don't change the ejukebox layout. In my case the ejukebox layout is altered when I wake up my PC. I suspect a problem with the user account managment, well maybe!




:cool: Pirk
View User's Profile Visit User's Homepage View All Posts By User U2U Member
Audiosoft
Super Administrator
*********




Posts: 3390
Registered: 3-11-2003
Member Is Offline

posted on 10-3-2007 at 01:12 AM Edit Post Reply With Quote
eJukebox automatically maximizes (if eJukebox is not minimized) when it detects that the screen resolution or the windows desktop workarea dimensions have changed. This is to prevent eJukebox layout overlaps after you change resolutions or the taskbar height.

I suspect the problem with hybernation and antivirus windows is that the desktop workarea dimensions are being modified by the system and that triggers eJukebox to maximize. I believe this could also be caused by having the Vista sidebar docked since that shrinks the desktop work area. Maybe the sidebar changes the workarea after hibernation? or maybe windows changes it for a second after booting back up? I am not sure...

If you want I will add an option to allow you to disable "maximize on desktop workarea change".




:cool: Audiosoft
View User's Profile E-Mail User Visit User's Homepage View All Posts By User U2U Member
Pirk
Posting Freak
*****


Avatar


Posts: 3973
Registered: 3-11-2003
Location: France
Member Is Offline

posted on 10-3-2007 at 09:30 AM Edit Post Reply With Quote
Audiosoft,

Well until now I've not really used the vista sidebar, but it can look good with eJukebox! Only in my case when I use the sidebar ej is never resized..

I've pressed the maximize button: this is exactely what I get after a hibernation! So it seems the resume process maximize eJukebox. Maybe you could make ej always stores (in the .ini file) its current layout, then it would simply read the last layout after the resume process or any "false" resolution change..

Here is a screenshot with the sidebar, I've resized eJukebox manually!:




:cool: Pirk
View User's Profile Visit User's Homepage View All Posts By User U2U Member
bhauxwell
Junior Member
**




Posts: 33
Registered: 3-21-2004
Member Is Offline

posted on 10-3-2007 at 02:11 PM Edit Post Reply With Quote
Just installed V 4.87 and it did not fix the problem with ejukebox, getting stuck whilst loading the options. I have fixed this by deleting the old database and forcing a database rebuild.
View User's Profile View All Posts By User U2U Member
Dragon_slayer
Member
***




Posts: 116
Registered: 10-20-2006
Member Is Offline

posted on 10-4-2007 at 05:19 PM Edit Post Reply With Quote
Audiosoft,
When choosing the video setting is it possible to get ej to display only the video albums (with album covers) instead of the artist song list? Also when itís on this setting dose ej play only videos or is it not possible to exclude mp3s?

I was also wondering if itís possible to choose a genre and instead of ej displaying artist song lists, have it display the albums and play mp3s on random exclusively from the selected genre?
View User's Profile View All Posts By User U2U Member
privatejz
Junior Member
**




Posts: 97
Registered: 3-27-2005
Member Is Offline

posted on 10-13-2007 at 04:15 PM Edit Post Reply With Quote
is there a certain version of ID3 tag that works better? i am still having issues with ej not importing all my songs. I converted some of my songs from id3 v2.2 to v2.4 and they then imported into ej but under the artists as 0 (zero) instead of the artist listed in the tag. i thought it was just with 2.4 tags but also found the same issue when i converted another album to v2.3. so i guess i am at a loss..

i am running 4.87

anything i should do to fix this?

thanks.

btw.. great version, other than not being able to import all my tunes things seem to working very well. great work.
View User's Profile View All Posts By User U2U Member
mchawk
Member
***




Posts: 161
Registered: 2-16-2006
Location: Germany
Member Is Offline

posted on 10-14-2007 at 09:49 AM Edit Post Reply With Quote
@privatejz
I've got problems by using ID3-Tag v2.4 as well as the APE-Tags, too: No or not correct imported songs.

I prefer to use ID3-Tag v2.3.

This will work: Jump to http://www.mp3tag.de/en/index.html
and install it.
* Go in the Options-Dialog to "Tags" => "Mpeg"
* Choose to read all tags
* uncheck "write APEv2"
* Choose ID3v1 and ID3v2
* Choose "ID3v2 2.3 UTF 16"
* Check all "remove"-Options.

Now you can simply rewrite "by pressing the save-button" correct your id3-tags.
Don't forget to reimport the changed files.

I'm editing all my mp3-ID-Tag-Files this way before I import them into eJukebox.
View User's Profile View All Posts By User U2U Member
privatejz
Junior Member
**




Posts: 97
Registered: 3-27-2005
Member Is Offline

posted on 10-14-2007 at 02:41 PM Edit Post Reply With Quote
well i did do all that and it didn't change anything. i actually had to change my tags to the id3v.2.3 iso-8859-1 to get my tunes to import correctly. thanks for turning me onto that tool however. should make converting easier.
View User's Profile View All Posts By User U2U Member
Audiosoft
Super Administrator
*********




Posts: 3390
Registered: 3-11-2003
Member Is Offline

posted on 10-25-2007 at 07:33 AM Edit Post Reply With Quote
4.88 is up



:cool: Audiosoft
View User's Profile E-Mail User Visit User's Homepage View All Posts By User U2U Member
Pirk
Posting Freak
*****


Avatar


Posts: 3973
Registered: 3-11-2003
Location: France
Member Is Offline

posted on 10-25-2007 at 06:51 PM Edit Post Reply With Quote
Thanks Audiosoft.
So no eJ Flow yet.. Luckily that we have the new albumlist to wait! ;)




:cool: Pirk
View User's Profile Visit User's Homepage View All Posts By User U2U Member
Alpheratz13
Junior Member
**




Posts: 61
Registered: 4-14-2003
Location: France
Member Is Offline

posted on 10-26-2007 at 03:34 PM Edit Post Reply With Quote
Thanks Audiosoft for your update ;)
Also thanks to Pirk for his new album list (his new skin).
View User's Profile View All Posts By User U2U Member
SimonC
Junior Member
**




Posts: 37
Registered: 4-20-2007
Member Is Offline

posted on 10-28-2007 at 09:23 PM Edit Post Reply With Quote
Settings on 4.88

I'm having trouble with 4.88.

It seems thatit isn't saving any of my settings when t exits the program.

EG - Display carousel, use external player etc.

Everything goes back to defaults when I launch EJ again.

It's happening on two different computers.

Is this a bug or am I perhaps forgetting to do something on the settings?

If I revert to 4.87 I have no such problems.
View User's Profile View All Posts By User U2U Member
Audiosoft
Super Administrator
*********




Posts: 3390
Registered: 3-11-2003
Member Is Offline

posted on 10-29-2007 at 01:15 AM Edit Post Reply With Quote
SimonC,

Thanks for the report. There is a problem in 4.88 with the carousel setting not being restored on next startup. I will get that fixed soon. The internal player/winamp settings seems to get restored fine here on XP. Are you on XP or Vista?




:cool: Audiosoft
View User's Profile E-Mail User Visit User's Homepage View All Posts By User U2U Member
mchawk
Member
***




Posts: 161
Registered: 2-16-2006
Location: Germany
Member Is Offline

posted on 10-29-2007 at 06:27 PM Edit Post Reply With Quote
audiosoft,

i think eJ has also a problem remembering the "always show duplicates"-flag.

mchawk
View User's Profile View All Posts By User U2U Member
Audiosoft
Super Administrator
*********




Posts: 3390
Registered: 3-11-2003
Member Is Offline

posted on 10-29-2007 at 07:20 PM Edit Post Reply With Quote
thanks mchawk, v4.89 will also fix the 'always show duplicates 'option so that the setting gets restored on startup.



:cool: Audiosoft
View User's Profile E-Mail User Visit User's Homepage View All Posts By User U2U Member
CiXel
Member
***




Posts: 290
Registered: 4-3-2003
Member Is Offline

posted on 10-30-2007 at 12:11 AM Edit Post Reply With Quote
The 2web Password screen is a welcome addition. Now I can listen without having people change songs on me!

Thank you.
View User's Profile View All Posts By User U2U Member
SimonC
Junior Member
**




Posts: 37
Registered: 4-20-2007
Member Is Offline

posted on 10-30-2007 at 07:19 PM Edit Post Reply With Quote
Hi Audiosoft

Thanks for the update. To answer your question , I am still on XP. Vista still too buggy for me as yet.

SimonC
View User's Profile View All Posts By User U2U Member
Audiosoft
Super Administrator
*********




Posts: 3390
Registered: 3-11-2003
Member Is Offline

posted on 11-7-2007 at 07:59 AM Edit Post Reply With Quote
4.89 is up



:cool: Audiosoft
View User's Profile E-Mail User Visit User's Homepage View All Posts By User U2U Member
Pirk
Posting Freak
*****


Avatar


Posts: 3973
Registered: 3-11-2003
Location: France
Member Is Offline

posted on 11-7-2007 at 09:51 PM Edit Post Reply With Quote
Thanks for your 4.89 Audiosoft.

I've me too just updated my Crimson Live Skin to version 2.1: It now includes a Artist Header background image for the Album List! Thanks a lot for adding this new feature. :)

Everyone can download my latest Crimson Live version from Here: http://www.audiosoft.net/forums/viewthread.php?tid=2228&page=1#pid77473




:cool: Pirk
View User's Profile Visit User's Homepage View All Posts By User U2U Member
Spaca
Junior Member
**




Posts: 19
Registered: 3-26-2006
Member Is Offline

posted on 11-9-2007 at 03:00 PM Edit Post Reply With Quote
eJukebox stuck loading options at startup

I updated eJukebox to v4.89 but it still stuck during loading options at startup. I tried to reinstall (uninstall, delete folder, reinstall), but it didn't help. :(

Operating system: VISTA 64BIT
View User's Profile View All Posts By User U2U Member
CiXel
Member
***




Posts: 290
Registered: 4-3-2003
Member Is Offline

posted on 11-9-2007 at 03:10 PM Edit Post Reply With Quote
Quote:
Originally posted by Spaca
I updated eJukebox to v4.89 but it still stuck during loading options at startup. I tried to reinstall (uninstall, delete folder, reinstall), but it didn't help. :(


I am seeing the same thing as well on 4.89 and now 4.88 on XP.
If I go back to the default empty database it will load up, but if I put back my original DB it stalls at 'loading options'. I definitely let EJ fully optimize the DB at shutdown last time too.
View User's Profile View All Posts By User U2U Member
Audiosoft
Super Administrator
*********




Posts: 3390
Registered: 3-11-2003
Member Is Offline

posted on 11-9-2007 at 09:30 PM Edit Post Reply With Quote
Spaca and CiXel what screen resolution are you using?



:cool: Audiosoft
View User's Profile E-Mail User Visit User's Homepage View All Posts By User U2U Member
CiXel
Member
***




Posts: 290
Registered: 4-3-2003
Member Is Offline

posted on 11-9-2007 at 09:53 PM Edit Post Reply With Quote
Quote:
Originally posted by Audiosoft
Spaca and CiXel what screen resolution are you using?


I'm at 1024 x 768
View User's Profile View All Posts By User U2U Member
Spaca
Junior Member
**




Posts: 19
Registered: 3-26-2006
Member Is Offline

posted on 11-12-2007 at 01:27 PM Edit Post Reply With Quote
Quote:
Originally posted by Audiosoft
Spaca and CiXel what screen resolution are you using?

1680x1050
View User's Profile View All Posts By User U2U Member
 Pages:  1  2
Post new thread Poll:

Go To Top

Audiosoft Home | Download EJukebox for Windows | Register EJukebox
©2016 Audiosoft Network. All rights reserved.
[queries: 16]
HTML5 Color Picker for CSS Opacity
Short Url Service with Stats